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Introduction

In this section...

“Circuit Envelope Simulation” on page 1-2

“Understanding the SimRF Environment” on page 1-3

SimRF™ provides a component library and simulation engine for designing
RF systems. It includes mixers, amplifiers, S-parameter blocks, and other
basic blocks for architectural design and modeling of wireless transceivers.
You can connect these components arbitrarily to form diverse architectures
and to model system-level impairments. SimRF enables simulation of

RF gain, noise, and intermodulation distortion commonly attributed to

RF amplifiers. It provides circuit envelope technology for simulating RF
impairments uniquely associated with mixers, including image rejection,
reciprocal mixing, local oscillator phase offsets, DC conversion, and DC
offsets. Equivalent baseband technology is also included, enabling fast
simulation of single-carrier cascaded systems.

Circuit Envelope Simulation

Time-domain simulation of radio-frequency (RF) signals is more challenging
than simulation of low-frequency signals. Modeling RF signals accurately can
require a large number of time steps. Circuit-envelope analysis is a solution
for modeling RF signals accurately in time, while reducing the necessary
number of simulation steps.

Performance hinges on two characteristics:

¢ RF systems operate on signals consisting of a carrier and a modulation.
The modulation can be accurately represented by a complex baseband
signal with in-phase (I) and quadrature (Q) components. In many RF
applications, the frequency of the modulation is orders of magnitude less
than the frequency of the carrier.

¢ Individual components of an RF system can be defined mathematically
by systems of equations that relate terminal voltages to branch currents,
with respect to time.
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By including the RF carriers in the mathematical representations of the
individual RF components, SimRF software calculates the effects of the RF
system on the RF modulation, according to the circuit envelope for each
carrier. The redefined system is mathematically equivalent to the original;
however, taking time steps on the order of the modulation instead of the
carrier produces equivalent results in less time.

Understanding the SimRF Environment

Groups of interconnected SimRF blocks and the algorithms that model the
RF system that they represent are collectively referred to in this manual
as the SimRF environment. In the SimRF environment, all blocks fall into
one of four categories:

® Blocks that operate within the SImRF environment contribute to the
physical representation of an RF system. Most SimRF blocks fall into this
category, including all blocks in the SImRF Elements and Sources libraries.
For example, a Resistor block can model a source impedance or part of
a matching network, and an Amplifier block could model a physical RF
amplifier. Both of these blocks model physical components.

Blocks within the SimRF environment connect via bidirectional SimRF
signals. SImRF signals are an implementation of Simscape physical signals
whose defined Through and Across variables represent current and voltage,
respectively. For an introduction to Simscape™ software and physical
signals, see Basic Principles of Modeling Physical Networks.

® Blocks that convert between the SImRF environment and other parts of a
model provide an interface from an RF system to a larger design. SimRF
Inport and SimRF Outport blocks fall into this category. For example,
you can construct a signal using blocks from Communications System
Toolbox™ or DSP System Toolbox™ libraries, and input that signal into
the SimRF environment using a SimRF Inport block.

® Blocks that operate outside the SimRF environment do not interact with
the physical RF system directly. All blocks that are not in the SimRF
library fall into this category, including blocks from Simscape libraries.

® The SimRF Parameters and Solver Configuration blocks connect to blocks
within the SimRF environment to manipulate the environment itself. They
are not strictly part of the physical system. However, they connect directly
with other SImRF blocks using physical connections. To use these blocks,
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connect them to any part of the RF system. Because they are not part of the
physical representation of the system, they have the same effect regardless
of where they connect within the environment.

To run models containing SimRF blocks, you must connect a Solver
Configuration block to the SimRF environment. Otherwise, the simulation
does not run. Additionally, to simulate carriers besides 0 Hz, or to model
noise in the SimRF environment, you must connect a SImRF Parameters
block to the SimRF environment.



Working with SimRF™ Software

Working with SimRF Software

In this section...

“Required and Related Products” on page 1-5

“Using the SimRF Documentation” on page 1-5

Required and Related Products

Several MathWorks® products are relevant to the tasks that you can perform
with the SImRF software and extend the capabilities of MATLAB®,

To install SImRF software, you must have the following products:

¢ RF Toolbox™ — MATLAB functions for modeling RF systems.

® Simscape — software tools for modeling and simulating multidomain
physical systems.

SimRF software benefits from, but does not require, installation of the
following recommended products:

¢ Communications System Toolbox — Simulink® blocks and MATLAB

functions for time-domain simulation of modulation and demodulation of
a wireless communications signal.

e DSP System Toolbox — Simulink blocks and MATLAB functions for
time-domain simulation of filtering of a modulated communications signal.

Using the SimRF Documentation
* “Expected Background” on page 1-5

¢ “What Chapters Should I Read?” on page 1-6

Expected Background

This manual assumes that you are already familiar with:

¢ Using MATLAB to write and execute scripts and functions.

1-5
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¢ Using Simulink to create and simulate block diagrams.

What Chapters Should | Read?

If you are using SimRF software for the first time, read Chapter 2, “Frequency
Conversion” to learn how to build SimRF models and to gain familiarity with
the SimRF environment. Once you are familiar with the concepts in this
guide, read the following sections of the documentation:

¢ For information on applying SimRF software to RF receiver design, refer
to the SimRF User’s Guide.

¢ To learn more about the applications of SimRF software and how SimRF
software interacts with other Simulink blocksets, see the Demos .

¢ For a detailed explanation of each SimRF block, see the Blocks —
Alphabetical List .

¢ For information on simulation using the Simscape platform, see Basic
Principles of Modeling Physical Networks.
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o “Specify the Circuit Envelope Simulation Environment” on page 2-2
e “Model an RF Mixer” on page 2-6
¢ “Filter Mixing Products” on page 2-14
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Specify the Circuit Envelope Simulation Environment

In this section...

“Access Circuit Envelope Libraries” on page 2-2
“Ground the RF System” on page 2-3

“Configure the SimRF Environment” on page 2-4

“Simulate the SimRF Environment” on page 2-5

This section of the tutorial shows you how to:
e Use a Solver Configuration block to provide local solver settings to the
SimRF environment

¢ Use a SimRF Parameters block to define the carriers and global noise
behavior in the SimRF environment.

e Use a Ground block to reference a model to electrical ground.

The Solver Configuration and Ground block are the bare minimum that
SimRF software requires in order to perform circuit-envelope simulation.
Models that are missing one of these two blocks do not run. In order to

simulate the SimRF environment at carrier frequencies other than 0 Hz, a
model must also contain a SimRF Parameters block.

To begin, open a new model by selecting File > New > Model.

Access Circuit Envelope Libraries

Open the SimRF library by clicking the Start button and selecting
Simulink > SimRF > Block Library (Circuit Envelope), or type

simrflib

at the MATLAB Command Window prompt.
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[ Library: simrfiibvi =] 3]
File Edit View Format Help
Circuit Envelops ‘ Equivaknt Bassband Idealized Bassband
SimRF Library 3.0
Copyright 2003-2010 The MathWorks, Inc.
Ready 100% Locked i

The SimRF library contains three sublibraries:

® The Circuit Envelope library contains blocks for circuit-envelope
simulation. This manual often refers to the Circuit Envelope library as the
SimRF library. The SimRF Getting Started Guide and SimRF User’s Guide

pertain exclusively to this library.

¢ The Equivalent Baseband and Idealized Baseband library contain blocks for
equivalent-baseband simulation. Refer to the Equivalent Baseband section
of the SImRF documentation for more information on using these blocks.

To continue, double-click the Circuit Envelope library.

Ground the RF System

Place a Ground block in your model:

1 In the SimRF library, double-click Elements to open the SimRF Elements
library.

2 Drag and drop a Ground block onto your model. In the library, the block
is abbreviated 'Gnd’.

Connecting SimRF models to ground provides an electrical reference for the
system, from which node voltages are defined. A SimRF model is grounded if:

e The model contains a Ground block that connects to the SimRF
Environment, or

¢ The model contains an Amplifier, Continuous Wave, Mixer, Noise,
Sinusoid, or S-Parameters block that is internally grounded. To internally
ground one of these blocks, select the Ground and hide negative
terminals check box in the block dialog box.
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Configure the SimRF Environment
To continue the tutorial:

1 Place a Solver Configuration block in your model. In the SimRF library,
double-click Utilities to open the SimRF Utilities library, then drag and
drop a Solver Configuration block onto your model.

2 Place a SimRF Parameters block in your model. If the SimRF Utilities
library is not already open, double-click Utilities to open it, then drag and
drop a SimRF Parameters block onto your model.

3 Connect the Ground, Solver Configuration, and SimRF Parameters blocks
to each other. The following figure shows one possible configuration.

-ioix]

File Edit View Simulation Format Tools Help
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A model can contain multiple Solver Configuration and SimRF Parameters if
all of the following conditions are met:

¢ Each Solver Configuration and SimRF Parameters block connects to a
separate SimRF environment.

® No two Solver Configuration or SimRF Parameters blocks connect to the
same environment.

¢ The separate SimRF environments are isolated from each other in separate
subsystems.



Specify the Circuit Envelope Simulation Environment

Warning Simulating more than one SimRF environment without
using subsystems is not supported.

Simulate the SIimRF Environment

To run the model, select Simulation > Start.

The model simulates according to the default settings of the Solver
Configuration and SimRF Parameters blocks and produces no output:

¢ In the SimRF Parameters block dialog, the Carrier Frequencies
parameter specifies a carrier of 0 Hz in the system. In the next section,
“Model an RF Mixer” on page 2-6, you specify additional carriers for
circuit-envelope simulation.

¢ In the Solver Configuration block dialog, the Use local solver check box is
cleared, so the model uses the specified global solver. The examples in the
SimRF User’s Guide show you how to configure the SimRF environment
to use a local solver.
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In this section...
“Build the RF System” on page 2-7

“Probe Circuit Envelopes Waveforms” on page 2-7
“Define Model Variables” on page 2-8
“Specify Block Parameters for RF Simulation” on page 2-11

“Simulate Frequency Conversion in an RF Mixer” on page 2-13

This section of the tutorial shows you how to:

e Use a Sinusoid block to model the envelope of an amplitude-modulated
(AM) waveform.

® Use a Continuous Wave block to model the constant envelope of an ideal
local oscillator (LO).

e Use a Mixer block to downconvert the AM waveform to an intermediate
frequency (IF).

Jr Jir

fiw far fro

The preceding figure illustrates frequency conversion. A signal modulated on
the carrier f,, mixes with a local oscillator at f; . The operation downconverts

frr to fir = fro — frr-

To begin, open the model you created in the previous section, “Specify the
Circuit Envelope Simulation Environment” on page 2-2, or type

ex_simrf_tut_env
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at the MATLAB Command Window prompt.

Build the RF System

Add blocks to the SimRF environment that create a working model for
frequency conversion:

® From the SimRF Sources library, drag and drop a Continuous Wave block
and a Sinusoid block onto your model.

®* From the SimRF Elements library, drag and drop a Mixer block and a
Resistor block onto your model.

Connect the blocks as shown in the following figure.

=] ex_simrf_tut_mixer * =[O x|

File Edit View Simulaton Format Tools Help
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Configuration
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This configuration specifies an AM waveform at the input port of the mixer,
an LO at the LO port of the mixer, and a 50-Q termination at the output
of the mixer.

For more information on organizing blocks on the Simulink canvas, see
“Changing a Block’s Appearance” in the Simulink User’s Guide.

Probe Circuit Envelopes Waveforms
At the output of the mixer:
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¢ From the SimRF Utilities library, drag and drop a SimRF Outport block
onto your model.

®* From the Simulink Commonly Used Blocks library, drag and drop a Scope
block and a Terminator block onto your model.

Connect the blocks as shown in the following figure.

=] ex_simrf_tut_mixer =10 x|

File Edit View Simulaton Format Tools Help
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This configuration uses a SimRF Outport block as a voltage sensor at the
output port of the mixer. The Simulink signal at the outport is the envelope of
the carrier or carriers specified in the block. A scope attached to the outport
plots the envelope. The Output parameter controls how signals are presented
at the output ports. To change the appearance of the block, follow one of

the workflows in the “Specify Block Parameters for RF Simulation” on page
2-11 section of this tutorial.

Define Model Variables

For models with blocks that share parameter values, specifying parameters
values using variables saves time and effort. For example, a frequency that is
specified in the Carrier Frequencies parameter of a SimRF Inport block
must also be specified SImRF Parameters block also appears in the Carrier
Frequencies parameter of a block that uses that carrier. If you specify the
parameter with a variable for the model using one of the following procedures.

To define model variables, use one of the following workflows.
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Using an Initialization Function to Define Variables

Simulink models run MATLAB code stored in the initialization function
(InitFcn) each time the model starts. The MATLAB code runs in the base
workspace. If the initialization function stores variables in the MATLAB
workspace, the variables are overwritten every time the model executes the
initialization function.

Most models in the SimRF User’s Guide use the InitFcn to define model
variables.

1 Open the Model Properties dialog box by selecting File > Model
Properties.

2 In the Callbacks tab, within the Model callbacks pane, select the
InitFcn node.

3 In the Model initialization function pane, enter the following MATLAB
code:

modulationAmplitude = 1;
modulationFrequency = 5e5;
LOAmplitude = 1;
LOFrequency = .95e9;
RFCarrier = 1e9;

For more information, see Using Callback Functions in the Simulink User’s
Guide.

Using the Model Explorer to Define Variables

From within the Model Explorer, add variables directly to the model
workspace. Model workspace variables do not interact with the base MATLAB
workspace.

1 Open the Model Explorer window by selecting View > Model Explorer,
or by right-clicking a block in your model and from the context menu,
selecting Explore.

2 On the Model Hierarchy pane, select the Model Workspace node for
your model.
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3 On the Contents pane, add the following variables to the workspace by
selecting Add > MATLAB Variable and editing the variable attributes.

Name Value
modulationAmplitude 1
modulationFrequency 500000
LOAmplitude 1
LOFrequency .95e+009
RFCarrier 1e+009
=10

File Edit View Tools Add Help

| zsmexBuUc.dlffoe@4R]Eaza

HSearm: |by Name ;I Name: | Search
Madel Hierarchy ‘% | e ‘ Contents of: Model Workspace |
52 Simuink Root

" B Base Workspace Column View: [Defalt = | ShowDetsils 5 obiectfs)
E}E ex_simrf_tut_mixer

| Name I BlockType |
. o HH modulationFrequency
Advice for ex_simrf_tut_mixer FH LoFrequency
- By Configuration (Active) HH modulationamplitude
B 2] Continuous Wave FH Loamplitude
- Pwl Gnd H recarrier
- 78] Miser
LR

SmRF Outport
SIMRF Parameters
Sinusoid

Solver Configuration

BEEE

Contents Search Results

For more information, see The Model Explorer: Overview in the Simulink
User’s Guide.
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Using the Command Line to Define Variables

Execute the MATLAB code in this section at the command line to assign
variables directly into a model workspace.

In the Command Prompt window, type:

hmdl = bdroot;

hws = get_param(hmdl, 'ModelWorkspace');
hws.assignin('modulationAmplitude’',1);
hws.assignin('modulationFrequency',5e5);
hws.assignin('LOFrequency',.95€e9);
hws.assignin('LOAmplitude',1);
hws.assignin('RFCarrier',1e9);

—_— o~~~

For more information on manipulating model workspace data, see Using
Model Workspaces in the Simulink User’s Guide.

Specify Block Parameters for RF Simulation
In this section, you:

¢ Configure the SImRF environment for multi-frequency circuit-envelope
simulation by specifying the Carrier frequencies parameter in the
SimRF Parameters block dialog box.

® Specify the attributes of the waveforms

¢ Configure global simulation settings.

To specify block parameters, use one of the following workflows.

Using Dialog Boxes to Set Parameters

1 Select Simulation > Configuration Parameters... to open the
Configuration Parameters dialog box. Specify the following parameters:
® Set Stop time to 1e-5.

® Set Solver to ode23t (mod. stiff/Trapezoidal).

2-11
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2 Double-click the Sinusoid block to open the Sinusoid Block Parameters
dialog box. Specify the following parameters:

® Set Sinusoidal amplitude in-phase to modulationAmplitude.
® Set Sinusoidal modulation frequency to modulationFrequency.

e Set Carrier Frequencies to RFCarrier.

3 Double-click the Continuous Wave block to open the block dialog box.
Specify the following parameters:

¢ Set Constant in-phase value to LOAmplitude.

¢ Set Carrier Frequencies to LOFrequency.

4 Double-click the SimRF Parameters block to open the block dialog box, and
set Carrier Frequencies to [RFCarrier - LOFrequency, LOFrequency,
RFCarrier, RFCarrier + LOFrequency].

5 Double-click the SimRF Outport block to open the block dialog box. Specify
the following parameters:

e Set Output to In-phase and quadrature.

e Set Carrier Frequencies to RFCarrier - LOFrequency.

Using the Command Line to Set Parameters

Execute the MATLAB code in this section at the command line to assign
variables directly into a model workspace.

In the Command Prompt window, type:

hmdl = bdroot;

set_param(hmdl, 'StopTime', '1e-5');

set_param(hmdl, 'Solver', 'o0de23t');

set_param([hmdl '/Sinusoid'],
'VA_I','modulationAmplitude’,
'Fmod', 'modulationFrequency’,
'CarrierFreq', 'RFCarrier');

set_param([hmdl '/Continuous Wave'],
"IVoltage', 'LOAmplitude’,
'CarrierFreq', 'LOFrequency');
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set_param([hmdl '/SimRF Outport'],
'CarrierFreq', 'RFCarrier - LOFrequency',
"OutputFormat', 'In-phase and quadrature');
set_param([hmdl '/SimRF Parameters'],
‘CarrierFreq',['[RFCarrier - LOFrequency, '
'LOFrequency, '
'RFCarrier, '...
'RFCarrier + LOFrequency]']l);

Simulate Frequency Conversion in an RF Mixer

Select Simulation > Start to run the model.

Models that contain SimRF Amplifier, Mixer, or S-Parameter blocks generate
files in the current MATLAB folder at run time. However, you can configure
the output location for these files by specifying a cache folder in the Simulink
Preferences dialog box. To specify a cache folder, open the Simulink
Preferences dialog box (File > Preferences) and specify a location on your
file system for the Simulink cache folder parameter. For more information
about the Simulink interface, see Simulink Preferences Window.

To view the results of the simulation, double-click the scope.

) Scope

EEIEEE R E

The Sinusoid specifies a 1-V amplitude for the modulation on f, which the
mixer downconverts to f The SImRF Outport block probes the intermediate
frequency and recovers the 1-V modulation amplitude. This value agrees with
a specified conversion gain of 0 dB in the mixer.
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In this section...

“Probe Multiple RF Carriers” on page 2-14
“Model an RF Filter” on page 2-16

“Simulate Filtering of RF Signals” on page 2-17

This section of the tutorial shows you how to:
e Configure a SimRF Outport block to probe multiple carrier frequencies
simultaneously.

e Model an analog filter in the SimRF environment using SimRF Capacitor
and Inductor blocks.

[

Low-pass filter 7.,
transmission !

Sy oy e

fiw far fro fre + T

The preceding figure illustrates low-pass filtering. Mixing f,, and f, , produces
signals on the carriers f;; = f,, — frrand f,, + frr Adding a low-pass filter to
the model reduces the power present in the high-frequency signal.

To begin, open the model that you created in the “Model an RF Mixer” on
page 2-6 section, or type

ex_simrf_tut_mixer

at the Command Window prompt.

Probe Multiple RF Carriers

The SimRF environment specifies the carriers f, , — frpm frp fLo a0d fro + frpm
but the SimRF Outport block probes only the carrier f,, — f; Examine
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the carriers f;, — frr and f;, + frr by changing the model according to the
following workflow:

1 From the Simulink Commonly Used Blocks library, add a Demux block to
your model.

2 In the Scope block dialog box, click the Parameters button, then set
Number of Axes to 2.

3 In the SimRF Outport block dialog box, set Carrier Frequencies to
[RFCarrier - LOFrequency, RFCarrier + LOFrequency]

4 Connect the blocks as shown in the following figure.

-Ioix

File Edit View Simulation Format Tools Help

DSHE| $BR|es 4|2 r mfes | [rom

olvar d
Configuiatian J_
5 SimRF

Ready 100% |odez3t v

5 Select Simulation > Start to run the model.

Models that contain SimRF Amplifier, Mixer, or S-Parameter blocks generate
files in the current MATLAB folder at run time. However, you can configure
the output location for these files by specifying a cache folder in the Simulink
Preferences dialog box. To specify a cache folder, open the Simulink
Preferences dialog box (File > Preferences) and specify a location on your
file system for the Simulink cache folder parameter. For more information
about the Simulink interface, see Simulink Preferences Window.

To view the results of the simulation, double-click the scope.

2-15



2 Frequency Conversion

2-16

) Scope

EEIEFEREEEIEEE

The first set of axes displays the modulation of specified carrier f; , — fpp This
carrier appears on the first set of axes because the Carrier Frequencies
parameter of the outport specifies it first. The second set of axes displays the
modulation at f,, + fzp The modulation of the upconverted signal has the
same amplitude as the modulation of the downconverted signal.

Model an RF Filter

To begin, open the model that you created in the “Probe Multiple RF Carriers”
on page 2-14 section, or type

ex_simrf_tut_probe

at the MATLAB Command Window prompt.

1 From the Elements library, drag and drop one Capacitor and two Inductor
blocks onto your model

2 Set the Capacitance parameter of the capacitor to 40e-12 F.
3 Set the Inductance parameter of both inductors to 50e-9 H.

4 Connect the blocks as shown in the following figure.
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ﬁ ex_simrf_tut_filter

File Edit View Simulaton Format Tools Help
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This configuration models a third-order low-pass Butterworth filter with
a cutoff frequency of 1 rad/ns, or about 0.159 GHz. The high-frequency
mixing product is in the stopband of the filter. The low-frequency product

is in the passband.

Simulate Filtering of RF Signals

To begin, open the model that you created in the previous section, “Model
an RF Filter” on page 2-16, or type

ex_simrf_tut_filter

at the MATLAB Command Window prompt. Select Simulation > Start

to run the model.

To view the results of the simulation, double-click the scope.
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) Scope

FEIEEEEEEIEEE

The filter attenuates the high-frequency signal at f, , — fz and transmits the
signal at f;, + fpr with minimal loss.

The SimRF documentation contains additional RF filter analysis and
simulation examples:

¢ The example Model an RF Filter Using S-Parameter Data uses an
S-Parameters block to model the filter shown in this tutorial.

® The demo AC Analysis of an RF System calculates the voltage transfer
function of an RF filter using harmonic balance analysis.



	toc
	Product Overview
	Introduction
	Circuit Envelope Simulation
	Understanding the SimRF Environment

	Working with SimRF Software
	Required and Related Products
	Using the SimRF Documentation
	Expected Background
	What Chapters Should I Read?



	Frequency Conversion
	Specify the Circuit Envelope Simulation Environment
	Access Circuit Envelope Libraries
	Ground the RF System
	Configure the SimRF Environment
	Simulate the SimRF Environment

	Model an RF Mixer
	Build the RF System
	Probe Circuit Envelopes Waveforms
	Define Model Variables
	Using an Initialization Function to Define Variables
	Using the Model Explorer to Define Variables
	Using the Command Line to Define Variables

	Specify Block Parameters for RF Simulation
	Using Dialog Boxes to Set Parameters
	Using the Command Line to Set Parameters

	Simulate Frequency Conversion in an RF Mixer

	Filter Mixing Products
	Probe Multiple RF Carriers
	Model an RF Filter
	Simulate Filtering of RF Signals




